Clutch hydraulic problems (2002 Protege5)


So last week my clutch hydraulic hose blew a leak. Obviously the clutch lost pressure, pedal went to the floor, and it stayed engaged. My uncle drove out to me, drove my car to his house with no clutch (the tranny took a beating), took the hose off, patched it, we bled the clutch, and it worked. The next day (Tuesday) I tried to pick up a new hose but nobody carried them. Ordered one online. Arrived Friday. I drove the car all week with the patched hose. It was slowly leaking, and the fluid in the reservoir was going down. Never went under minimum. Just before I was about to change the hose, I tried pulling my car around...and the clutch stopped working. I figured the patch had just finally gave up. Upon inspection, the fluid was above minimum, and the patched hose didn't appear to be leaking. I had the new one so I replaced it anyway.

That's the story, now the problem.

Changed the hose and went to bleed the system. Clutch just won't build pressure now. Topped the fluid up, opened the bleeder, pushed the pedal in, and I get air and little spurts of fluid coming out. Close the bleeder, pull the pedal back up...repeat. must have done this 100 times. The fluid in the reservoir never moves...stays at the same level, and the clutch never builds pressure. I feel like when I open the bleeder after pulling the pedal back up...I feel air getting sucked into the bleeder screw. I even took the bleeder screw out, cleaned it and wrapped the threads in Teflon tape. Still feels like it's sucking air IN when I open it.

Because the clutch stopped working right before I changed the hose...with no apparent signs of leak in the hose...or anywhere else. I'm concerned something else broke.

Did I blow the master cylinder? The slave cylinder? Is there a clog in the line? I'm at a loss. My uncle is coming out to save the day again today...he's bringing his bleeder kit. We'll see if it helps.

Oh it's an 02 P5. Heavy kms. 248 xxx. Clutch is good still. Only a year old. Pulls great when it's working. Transmission is a bit beat up. Trouble shifting into first sometimes, grinds into 3rd if you don't let it go fully into neutral and push it gently into 3rd. If you just slam it in it almost always grinds for 3rd.
There's a really good chance that either clutch master cylinder and/or slave cylinder have failed.

The leaking hose may have been the last straw.

The seals leak internally and stop pushing fluid but it doesn't leak out.

They're not too much money.

It was the master cylinder. We followed the fluid down from the reservoir, and it was coming out the hose from the reservoir to the master, but wasn't getting passed the master. We took the master off and forced an airlock out. Hooked it back up and it worked fine after. Taking out and putting the master back in is a pain in the ass.

Built pressure right after and voila! The clutch works again.