Christmas Motor Mount Blow Out!!!

Status
Not open for further replies.
Hey guys, we are WAY over stocked on the legendary Protg Motor mounts made by the Medieval Motorsports. So we thought it would be jolly of us in the Christmas spirit and all, that we offer you guys a huge discount on them! (cabpatch)

Protg Front Mount $40 shipped
Protg Rear Mount $50 shipped
Protg Side Mount $60 shipped
Protg Transmission Mount $80 shipped

All 4 Mounts(Best Deal) $199 shipped

These discounted Prices will go until Jan 1, 2009, please send payment via Paypal to *******************@yahoo.com and please and to the notes which mount you want

Pictures;

1. Front Mount
2. Transmission mount
3. Passenger side Mount
4. Rear mount
 

Attachments

  • Front%20mount.jpg
    Front%20mount.jpg
    17.2 KB · Views: 624
  • protegetrannymount.JPG
    protegetrannymount.JPG
    18.2 KB · Views: 504
  • PS mount.jpg
    PS mount.jpg
    26.3 KB · Views: 505
  • rearmount.jpg
    rearmount.jpg
    12.7 KB · Views: 471
Last edited:

Sport23

Member
Contributor
:
2003.5 MSP
Good news, I had a pickup notification in my mailbox today! I should have my mounts in the morning. To answer your question Darkstar, my payment was sent on the 30th. thx
 

jmv

Member
:
2003 MSP #1475
Got my front and passenger side mounts on today...

Driveability is much better, i like the way the car drives now. I had 2 issues with the parts themselves, though... for the front mount, i had to use a screwdriver to pry the mount far enough over to get the bolt holes to line up with the frame, i just barely got it over far enough... this just concerns me that if it doesn't fit super well it may lead the mount to wear faster. Then, for the passenger side mount, it came with a 3" bolt and a nylon locking nut, but the bolt was just barely long enough to get the nut onto, wouldn't reach the nylon. So i had to go buy a 3 1/2" bolt.

Vibrations definitely ARE increased over stock. I don't think the increase is too drastic, and honestly i wouldn't mind if it was, however something potential buyers might need to take into account is not only the amount of extra vibrations it may cause, but the incredibly annoying rattles that it may bring out on an 'older' car. Theres a high pitched rattle now basically any time i'm above idle with a load, and its fairly loud. I looked around but couldn't find the culprit... i HAVE to fix that or it will drive me insane. The vibrations are not very bad though.
 
Last edited:

DS motorsports

Banned
Contributor
Got my front and passenger side mounts on today...

Driveability is much better, i like the way the car drives now. I had 2 issues with the parts themselves, though... for the front mount, i had to use a screwdriver to pry the mount far enough over to get the bolt holes to line up with the frame, i just barely got it over far enough... this just concerns me that if it doesn't fit super well it may lead the mount to wear faster. Then, for the passenger side mount, it came with a 3" bolt and a nylon locking nut, but the bolt was just barely long enough to get the nut onto, wouldn't reach the nylon. So i had to go buy a 3 1/2" bolt.

Vibrations definitely ARE increased over stock. I don't think the increase is too drastic, and honestly i wouldn't mind if it was, however something potential buyers might need to take into account is not only the amount of extra vibrations it may cause, but the incredibly annoying rattles that it may bring out on an 'older' car. Theres a high pitched rattle now basically any time i'm above idle with a load, and its fairly loud. I looked around but couldn't find the culprit... i HAVE to fix that or it will drive me insane. The vibrations are not very bad though.

PM me about the rattle.

Thats not normal, and I want to help you get it fixed
 

jmv

Member
:
2003 MSP #1475
Yeah i dunno if theres much to be done except for me track down whatever has come loose over the years and has started to rattle. I do really love the feel of the car now, its made a huge difference even with just the front and side mounts in.
 

DS motorsports

Banned
Contributor
Yeah i dunno if theres much to be done except for me track down whatever has come loose over the years and has started to rattle. I do really love the feel of the car now, its made a huge difference even with just the front and side mounts in.


as for the vibrations, give the mounts a few days to break in, and then the vibration will go away
 

msptn03

Member
:
Mazda Speed Protege
I was trying to put my side mount on today and i could get all my old stocker bolts off except one. i used torque wrench and everything and i could NOT get that bolt to budge loose! ne suggestions to help me get it loose? also was the new side mount suppose to comef with botls? or just use the stockers?
 

jmv

Member
:
2003 MSP #1475
I had to use an impact wrench for the large bolt on the front mount... if you don't have one, see if anyone you know has one you could borrow, that'll make it real easy. And you don't need a huge air compressor either... i hooked the wrench up to the compressor i use for tires, and it was good enough for a quick burst to get the bolt started, then i could get it with a ratchet. Aside from that, possibly find a pipe or something to slip over the end of a ratchet, to make it longer, to give you more torque.

My side mount had the main bracket, an L bracket, and then the bolt and nut to go through the bushing. Other than that, you can reuse all the stock hardware, except for the small brace that goes over to the fender and its accompanying bolts.
 
Last edited:

NCZ13

Member
you guys do installs at your shop?

the rear motor mount is a b**** on these cars, and would probably be much easier on a lift rather than 2 stands
 

ForceFed

Member
:
Trailblazer SS AWD ....Still a Mazda Junkie Though.
AV Status?

Are you going to get your AV Status taken care of....Or are you Exempt from following the rules like the rest of the Vendors here?

Its been SOme time now....Yet you are still allowed to continue sales?

Just saying.
 
Status
Not open for further replies.