2013~2016 TPMS and SCBS Inspection required

:
2014 CX-5
Hello all,

I have a 2014 CX5 GT with Nav and Tech and it recently threw up a few warning messages. First one is TPMS Inspection required and the other is SCBS Inspection required. It also has the TPMS, TCS and the red exclamation lit. I have attached pics of the dash with the messages. Is there a way to read the codes to find out what part to start looking at (instead of going to the dealer)? I have an ELM ODBC Bluetooth scanner and using Torque light but was unable to read any codes. Is there any recommended software I should use instead? I've see online there is also MotorData OBD and CarScanner anyone have luck reading the Mazda specific codes with either of them?

Googling says it's either the sensor array on the windshield, wheel speed sensors or break sensor. I've checked the windshield and it's clear of all obstructions. I've also tried to reset the warnings by disconnecting the battery but that did not work.

Short of going to the dealer, anyone have next steps?

Thanks!
 

Attachments

  • 20200924_204704.jpg
    20200924_204704.jpg
    151 KB · Views: 132
  • 20200924_204706.jpg
    20200924_204706.jpg
    156.8 KB · Views: 136
:
2014 CX-5
Quick Update on how this played out:

I bought the BlueDriver scanner from Amazon ($120) and it was able to read the codes from the ABS computer. It came up with 6 codes. Notable this one: "C0037-15 Left Rear Wheel Speed Sensor : Circuit Short To Battery or Open". I picked up a new sensor from my local dealer ($75) and installed (~30 mins of rust covered grief). Then a re-scan and clear of the codes and I was on my way!

Cheers!
 

yrwei52

2016 Mazda CX-5 GT AWD w/Tech Pkg
Contributor
:
Plano, Texas, USA
Quick Update on how this played out:

I bought the BlueDriver scanner from Amazon ($120) and it was able to read the codes from the ABS computer. It came up with 6 codes. Notable this one: "C0037-15 Left Rear Wheel Speed Sensor : Circuit Short To Battery or Open". I picked up a new sensor from my local dealer ($75) and installed (~30 mins of rust covered grief). Then a re-scan and clear of the codes and I was on my way!

Cheers!
Thanks for the update. Did you read the ABS codes via OBDII port with BlueDriver scanner?