1998 Mazda 626…Doesn’t crank, any ideas?

I have a 98 mazda 626 2.0l manual. I replaced the transmission and got it all put back together, but now I'm getting nothing from the starter. I pulled the starter and bench tested it. It works fine. I checked all my connections everything is plugged in and I don't have any loose grounds. Any ideas? The transmission is currently dry with no fluid. I'm just trying to get some crank so I can hook fuel lines back up to make sure I don't get them flipped around, but I don't see that being a problem.
 
:
Northeast
:
2020 CX-5 Tour
I'm not familiar with your vehicle, and it could be that this 25 year old vehicle didn't use a starter relay. How about testing at the solenoid to see if there's power and ground with the key turned to start? One possibility is a problem with the neutral safety switch, which in turn would leave the starter circuit open.
 
I'm not familiar with your vehicle, and it could be that this 25 year old vehicle didn't use a starter relay. How about testing at the solenoid to see if there's power and ground with the key turned to start? One possibility is a problem with the neutral safety switch, which in turn would leave the starter circuit open.
Bypassed the neutral safety switch still nothing
 
Have you tested for power and ground at the starter solenoid?
Yes. Voltmeter shows good connection all the way to the starter. I got it to work ended up putting it back in the car and was checking volts on a couple things.... turned the key and it started cranking. So I have no idea what the problem was, but it seems to be working now.