Another post about 2016 CX-5 brake drag from unmodified rear EPB calipers

I've been experiencing brake drag on both rear wheels due to the TSB R052/16C (faulty rear calipers that don't disengage the EPB fully). I noticed the problem while replacing the brake pads and rotors. The outside pad was worn almost completely down, while the inside pads were barely worn. The rotors had bluish heat marks and white heat rings consistent with the images in the TSB. However, I'm also worried I might have damaged something while doing the brake job.

I had put the EPB in maintenance mode before starting the job, and was able to compress the pistons just fine on both sides with a C clamp (straight back, did not rotate). After I finished assembling, I tried taking the EPB out of maintenance mode. I can hear the motors going, but they seem to go for far too long. After they stop, the parking brake symbol is still flashing red on the dash, the EPB button is flashing, and I get the steady parking warning light with the !. The infotainment system has a fault saying "Electronic parking brake malfunction". And trying to turn the parking brake on doesn't do anything. Luckily, the EPB is not engaged at all and I can drive normally.

I'm not sure if the EPB fault is due to something I did, or if it's just related to the bad calipers.

What do you think my course of action is? I think I need to replace the calipers with the modified ones from the TSB. Will this be covered under my extended warranty? I checked the warranty docs, and I am covered through 2023 and it says it includes calipers.