Mazda Connect Firmware 74.00.230A

:
2016 CX-9 GT
Question for those of you with v74.x in North America. Recently rented a new Mazda in Israel, and noticed CarPlay there didn't exhibit the same restrictions (e.g. no keyboard / limited length lists when the car is in motion). I was wondering if it is a regional difference, or MazdaConnect finally ditched this "safety feature".
My US CX9 has v70.x for the moment, and still can't scroll through the lists and have to rely on Siri 100% when in motion.
Still limited in the NA version. Kind of annoying. I end up picking up my phone and searching maps on there or changing playlists on Spotify if the 10 they have on the CarPlay screen aren’t what I’m looking for. Would be safer IMO to let the driver use the touch screen
 
Hello, today I updated to 74.00.311A EU N. The car was on ACC but the car power off I don't know why (I touch the clutch pedal few minutes ago, like the instructions). Then I put ON (not ACC) and the process started from 0% to 100% without issues. There will be any problem? I have to do something now, any code combination or clear any error? My batery is not full, and after the update the car disabled the i-start, maybe it is the cause? Thanks
 
I am extremely far from being an expert but would imagine the car will disable i-start until a significant charge is detected in the battery. The only 'issue' I had was with the Active Driving Display which was fixed with a factory reset.
 
:
2016 CX-9 GT
Why do you want 70.00.100NA? Am I forgetting something in the upgrade process? I have the file, just not sure why not the newest version
 
Why do you want 70.00.100NA? Am I forgetting something in the upgrade process? I have the file, just not sure why not the newest version
Like in my case I am coming from version59.00.441NA N so I need first to update to 70.00.100NA before I can go to the newest available. That's why we need that.
 
:
ASH8
Hello, today I updated to 74.00.311A EU N. The car was on ACC but the car power off I don't know why (I touch the clutch pedal few minutes ago, like the instructions). Then I put ON (not ACC) and the process started from 0% to 100% without issues. There will be any problem? I have to do something now, any code combination or clear any error? My batery is not full, and after the update the car disabled the i-start, maybe it is the cause? Thanks
You are lucky with weak battery you did not brick CMU.
i-stop will not work when Battery is detected as being weak in charge or CCA, cranking amps....buy a new battery.
 
You are lucky with weak battery you did not brick CMU.
i-stop will not work when Battery is detected as being weak in charge or CCA, cranking amps....buy a new battery.
Battery now it's OK. But I will look for new one.

Some issues on this v74 version, Spotify cover art via Bluetooth doesn't appear on some albums, anybody has this too?

Sorry for the off-topic, but there is any Windows based software to communicate via OBD to the car? I have a Toyota and I used Toyota Techstream with OBD-USB adapter. Any software for this adapter for Mazda? Thanks
 
:
2019 Mazda CX-9 Signature
Battery now it's OK. But I will look for new one.

Some issues on this v74 version, Spotify cover art via Bluetooth doesn't appear on some albums, anybody has this too?

Sorry for the off-topic, but there is any Windows based software to communicate via OBD to the car? I have a Toyota and I used Toyota Techstream with OBD-USB adapter. Any software for this adapter for Mazda? Thanks
Try Car Scanner ELM OBD2 from the Windows store
 
Is it possible to get the 74.00.230 update for north America? I did the upgrade to 70.000.367 myself about a year ago and that worked well. Like many other posts hoping it starts up faster.
 

Attachments

  • 20220813_112640.jpg
    20220813_112640.jpg
    122.8 KB · Views: 75
Is it possible to get the 74.00.230 update for north America? I did the upgrade to 70.000.367 myself about a year ago and that worked well. Like many other posts hoping it starts up faster.







I think you can go straight to the latest avail le from they one you are at now , the current is 74.00.311 NA.
 
:
2016 CX-9 AWD
I am assuming most people upgrading to 70+ is adding the CP/AA media hub. But is there any issue with upgrading just the firmware and not installing a new media hub till some time later?
 
Try to Pm me or some other guys around, they don't post files links anymore and you can't share without the person's consent, that's what I learned the last time some nice guys helped me here.
Finally got the chance to upgrade Friday, worked perfectly and very easy. Thanks Famsfirst for your assistance.
 
I am assuming most people upgrading to 70+ is adding the CP/AA media hub. But is there any issue with upgrading just the firmware and not installing a new media hub till some time later?
From what I have seen so far I would not expect it to be a problem. I do have the CP/AA module, self installed for the 70 upgrade, but I have seen anything that would indicate it will fail or have issues without it.
I think you can roll back, maybe someone that know more can answer that. Is it possible to downgrade?
 
Hey everyone. I have CX-9 with the 9-inch screen. The system shows there is "Network Management" section where you enable Wi-Fi. However, Apple CarPlay can't be added without using the USB cable.

This the system revision for your feedback. Thanks
1664783428825.png
 
Hey everyone. I have CX-9 with the 9-inch screen. The system shows there is "Network Management" section where you enable Wi-Fi. However, Apple CarPlay can't be added without using the USB cable.

This the system revision for your feedback. Thanks View attachment 313431
I just went to the dealership and was charged equivalent to $40 to diagnose and upgrade to the latest software, 74.00.311 4A N. Still can't use wireless CarPlay

I just don't understand November MY2021 wouldn't be compatible with wireless CarPlay! Are there any other parts prevent this to work?


Any chance I can determine the current CMU hardware revision (model) without opening the dash up?
 
Last edited: