Losing power and Engine light.. HELP PLEASE!!!

rapter

Member
Contributor
:
2006 Mazdaspeed 6 Grand touring
Ok so i have the car for a long time and only done a CAI and RMM in the last i dont know 400 miles on it.

I also just went to the detail place and they detailed my engine as well, high end place though they do high end cars, so i would think they know what they are doing.

in any case.

Car starts fine, drove it a few blocks let it warm up it was about +5 C so around i dont know 45F lets say

If i go slowly through the gears i have no problems,
now if i step on it harder when the Turbo kicks in at 3000rpm i start to get some sluggish movment and if i keep doing it the Engine light starts blinking for 20 secs or so and than stays Solid.
I upplugged the battery for a few mins, and started it up NO ENGINE LIGHT, than same thing but this time no sluggish momvment if i let the car drive for longer, but than few hours latter driving home I got the SAME THING happen.
so Im really worried is this a Sensor?? fuel problem??
any suggestions would be great I will go to a shop and see if the can read the ECU to see what Code i get!

thanks
 

Spooler

Member
:
2007 Mazdaspeed 6
Already 5 C in Calgary!!! Still around 13 C in the morning in Mtl. It could be related to the car wash. I would check if the CAI is wet (and kick their ass if it is) or if there is water close the ignition system. Tough call without the code.

Just curious, did you replace your RMM because it failed? I am having issues with my second gear when the car is cold, so I am doing some troubleshootign myself.
 

zinger002

Member
:
2006 Mazda Mazdaspeed6
you are getting a random misfire. take off the coil packs, remove your plugs and inspect them for any issues or pitting. make sure they are gapped to roughly .028", now put them back in a random order. do the same with the coil packs and see if the problem goes away.
 

spec2speed

Member
:
2006 Mazdaspeed 6
Hey whats up? Fellow Calgarian here. I'm almost certain there's moisture somewhere in your intake. Ask the detail place if they sealed the intake filter with a bag before cleaning the engine bay. If there is moisture somewhere in the piping, remove the entire intake (from TIP to filter) and shop vac everything, except the filter. Let that air dry.

Just out of curiosity, which detailer did you take it to.
 

rapter

Member
Contributor
:
2006 Mazdaspeed 6 Grand touring
so here is the low down

FIXED!!!!

and thanks for all the tips guys!

no1 I cleaned the MAF sensor with a MAF cleaner since there was black crap all over it that was easy.

than YES I FOUND WATER in Cylinder 2 all over the coils and sparkplugs.
I used a special spark plug cleaner did it too all 4 cylinders to make sure let them dry
put everything back in random order.
Fired it up i would say for about a min it was a bit weird prolly just cleaning.

than back to normal NO CEL took it for a test drive and NOO STUTTER!
so im happy. with myself that is.

As for the place called "DETAILZ" im going over there tomorrow and giving them some advice and seeing what they can do for me for compensation(i doubt i will get anywhere)
but ill be nice about it. even though it cost me like 3 hours of work today.

yeah Calgary got cold today but sunday is suppose to be 24C normal for these drops.
Anyways that is all the scoop
what a DANM HEADACHE!!!!
 

rapter

Member
Contributor
:
2006 Mazdaspeed 6 Grand touring
kinda of on the RMM it didnt fail but i sure had a hell of time shifting once i added some extra power to the car.
1st to 2nd and 2nd to 3rd were always the worst.
Replaced it with the new SURE R 6 and wow hell of a difference will give you fair warning.
if you have the A/C on you can DEF notice the vibes in the car, but i rarely have it on and its a huge difference in shifting.
 

Spooler

Member
:
2007 Mazdaspeed 6
Glad to hear your MS6 is back in shape. Yeah, sometimes who we think are the pros are not that great (like the dealership leaving my airbox opened...). Thanks for your feedback on the RMM. I have an oil change scheduled for next week, I'll make them take a look while I'm there. My 1st to 2nd seems to occur when the car is cold (feels like when you try to go back to first too fast, that rubbery feeling), it started doing it this year.
 

rapter

Member
Contributor
:
2006 Mazdaspeed 6 Grand touring
Glad to hear your MS6 is back in shape. Yeah, sometimes who we think are the pros are not that great (like the dealership leaving my airbox opened...). Thanks for your feedback on the RMM. I have an oil change scheduled for next week, I'll make them take a look while I'm there. My 1st to 2nd seems to occur when the car is cold (feels like when you try to go back to first too fast, that rubbery feeling), it started doing it this year.

ahhh yeah no problem,
Yeah i would take a look at it for sure, you can always take a look at it yourself too when at the dealership see if you can get under the car.
if you see any cracking on the rubber portions get it replaced!
When i took it out i was SHOCKED to find this is whats holding the main part of my engine its super flimsy.
Now can go pick up the girlfriend at the airport in style.... hehehe :)
 

zinger002

Member
:
2006 Mazda Mazdaspeed6
you think our stock rmm is bad?

i'm building a 1989 sunbird gt turbo and its getting the 6 speed from a Chevy cruze...
and while i was doing research i found that those cruzes have plastic mounts....
now that is cheap and flimsy!!!
 

rapter

Member
Contributor
:
2006 Mazdaspeed 6 Grand touring
you think our stock rmm is bad?

i'm building a 1989 sunbird gt turbo and its getting the 6 speed from a Chevy cruze...
and while i was doing research i found that those cruzes have plastic mounts....
now that is cheap and flimsy!!!

hahaha, wow "PLASTIC" lol 89 sunbird nice car! whats the paint job gonna be like?
 

rapter

Member
Contributor
:
2006 Mazdaspeed 6 Grand touring
Hey whats up? Fellow Calgarian here. I'm almost certain there's moisture somewhere in your intake. Ask the detail place if they sealed the intake filter with a bag before cleaning the engine bay. If there is moisture somewhere in the piping, remove the entire intake (from TIP to filter) and shop vac everything, except the filter. Let that air dry.

Just out of curiosity, which detailer did you take it to.

Just wanted to let you know fellow Calgarian, that the shop is Detailz but i went in today to complain and i happen to get the owner of the place.
Nice fella explained to him what happened.
and he gave me a Free interior Detailing package!
So im happy they recognized the mistake and gave me something in return.