Horn Not Working in 2016 CX5

Hi All:
Today I realized that my horn is not working when I push the horn buttons on the steering wheel. It does, however, still sound when I lock the car with the keyfob. Since this would seem to indicate the horn itself is not bad, any thoughts about what could be the culprit?
 
:
Mazda Protege DX
Oops I didn't read the diagram clearly. if the horn works with remote then the problem does not lie with the relay or the fuse.

Since bcm can command the horn to turn on, in your situation the horn was turned on by vehicle locking.

Maybe the problem lies with the steering wheel side (horn switch) let me see if i can find another diagram...
Screenshot_20210205-161313_Chrome.jpg
 
Upvote 0
:
Pueblo county CO
:
CX-5 Sport 16.5 6M
When did this problem start?

If the horn is working it looks like you need to see if anything else is wrong or not working, especially in the steering wheel area.
 
Upvote 0
When did this problem start?

If the horn is working it looks like you need to see if anything else is wrong or not working, especially in the steering wheel area.
aha...I just checked and none of the buttons on the left of the wheel work (phone and audio controls). Cruise control and such on the right are working.
 
Upvote 0
:
Mazda Protege DX
aha...I just checked and none of the buttons on the left of the wheel work (phone and audio controls). Cruise control and such on the right are working.
That's pretty helpful, base on that I would say you gotta take a quick look at the wiring/connectors.

Quick test will be able to tell you if the horn switch is working and from that point on it is just chasing what's shorted or disconnected.
 

Attachments

  • Screenshot_20210205-161929_Chrome.jpg
    Screenshot_20210205-161929_Chrome.jpg
    111.9 KB · Views: 35
  • Screenshot_20210205-161953_Chrome.jpg
    Screenshot_20210205-161953_Chrome.jpg
    61.7 KB · Views: 33
Upvote 0