Help! Struggled 10h+ for wheel control using an android stereo/radio (2016 CX-5)

Hi all!

I am surprised to find this active forum to help people with old cars!

The original stereo has no screen, so I tried to upgrade it with the following Android one:

However, I found the harness cable is completely different from standard ones from Amazon or diagrams online.

I spend 10+ hours on this, and succesfully to get the audio going, but the wheel control is still not available.


I tried to connect the swc1 and GND with all pins from both harnesses, but the wheel control is still not working.

Do I need a canbus? I am confused that some YouTube videos use canbus for wheel control.

This is my last hope.
Under this market, I might drive the old car longer than planned.
Really appreciated.
 

Attachments

  • IMG_0512.JPG
    IMG_0512.JPG
    96.9 KB · Views: 30
  • PXL_20220610_222026001.jpg
    PXL_20220610_222026001.jpg
    44.7 KB · Views: 30
  • Sa1c7e0b1e43e4f3a80493a3995b4a247x.jpg
    Sa1c7e0b1e43e4f3a80493a3995b4a247x.jpg
    82.4 KB · Views: 30
  • Capture2.PNG
    Capture2.PNG
    269.9 KB · Views: 30
Last edited: