2021 CX-9 won’t keep time when it’s on GPS setting under clock setting

K-Lat

Member
Hey, we just bought a 2021 CX-9 GS-L and was wondering if you have to have navigation to use the GPS clock function. Ours won’t keep time when it’s on the GPS setting under the clock setting. Our dealer said we have to have navigation in order for the function to work which seems odd to me as navigation is just a SD card you load your maps from, correct? Just wondering if anyone else who doesn’t have nav can use the gps setting for their clock. Thanks
 
:
2019 CX9 GT AWD
If I remember correctly getting clock from GPS is not related to navigation. The car just uses GPS signal to retrieve the current time. In practice, once you start the car the time is not set. It needs a few sec to get the time from GPS and start displaying the right time. Surely if you're inside and don't see the sky the time can not be acquired.
 
Hey, we just bought a 2021 CX-9 GS-L and was wondering if you have to have navigation to use the GPS clock function. Ours won’t keep time when it’s on the GPS setting under the clock setting. Our dealer said we have to have navigation in order for the function to work which seems odd to me as navigation is just a SD card you load your maps from, correct? Just wondering if anyone else who doesn’t have nav can use the gps setting for their clock. Thanks
I just noticed my clock was wrong last week. I had to go 'manual mode' to set and stay correct. When I go back to GPS it was off by 2 hrs. What's strange for me is that I've had my car for almost a year now and it was working fine before (on GPS mode). So not sure why its doing that.
 
:
2019 CX9 GT AWD
I just noticed my clock was wrong last week. I had to go 'manual mode' to set and stay correct. When I go back to GPS it was off by 2 hrs. What's strange for me is that I've had my car for almost a year now and it was working fine before (on GPS mode). So not sure why its doing that.
Maybe your time zone is set incorrectly.
 
:
CX9
My 2019 CX-9 GT clock gradually gains time and never corrects itself and I must reset it manually. GPS works with my NAV system just fine but doesn't seem to have any influence on the clock.