2013 CX-5 Traction, Tire Pressure, Check Engine Light, Trouble Running

Hello,

traction control, tire pressure light, and check engine light came on all at the same time.
the car barely kept minimum rpm and shuts off.
when I scan the car I didn't get a misfire code.
just got
P0102 mass or volume air flow sensor a circuit low
P061B internal control module torque calculation performance.

someone else has experienced this and had a fix or has suggestions on how to fix it?

Thank you
 

sm1ke

Work In Progress..
Moderator
Contributor
:
Canada
:
'18 CX-9 Signature
Yep, check the battery. Is it the original battery that came with the car? If so, it's due for replacement anyway, so that would be where I'd start.
 

CarpeDiem

Under Pressure
:
Superstitions
:
2021 CE Turbo
Concur, likely the battery, no matter how new or old it is. Modern vehicles with all their computers are very sensitive to voltage levels under load. Be certain to electronically load test the battery, not just a voltage check. Stores like AutoZone will do it for free.
 
Yep, check the battery. Is it the original battery that came with the car? If so, it's due for replacement anyway, so that would be where I'd start.
Thanks, the thing is the battery looks fine, I check voltage and got a 12.7
And the car starts with no issue.
 
:
Northeast
:
2020 CX-5 Tour
Thanks, the thing is the battery looks fine, I check voltage and got a 12.7
And the car starts with no issue.
What's the running voltage, assuming you can keep it going long enough to check it?
 
:
Pueblo county CO
:
CX-5 Sport 16.5 6M
The fact that three unrelated lights came on simultaneously might mean something you might be able to clear along with the codes, etc. by a cold shutdown. Remove a battery cable long enough for all circuits to die down then reattach and try to start it.
Maybe a code that makes some sense will come up.
 
:
GA prior 16 CX5 GT
:
20 CX5 GT + Prem
You might have trash or dirt on mass air flow sensor. There are some threads on how to check/clean it...