2007 CX-7 AWD. OBD scanner won’t link to ECU after new battery

My car sat in the driveway all winter because the key had been lost. Finally got a new one made. Battery was dead. Tried hooking it up to a trickle charger, couldn’t keep the charge so I bought a new one last weekend.

I also put in about 2 gallons of fresh regular gasoline. (Didn’t siphon out the old stuff).
Car started, and then died idling. Started it up again and tried to give it some juice but stepping on the pedal didn’t revv it up at all. No jump in rpms. Backed it out on to the street and drove around the block, even with pedal to the floor it wouldn’t go over like 10 mph. Parked it. Noticed check engine light was on. Went to autozone and got an Innovo 2030RS OBD scanner.

It connects, it’s getting power. But it fails to link to the ECU and just reads out “ERROR”. I tested all the little fuses in the dash and the engine bay. All good.

Side note, there was a pile of acorns on my old battery when I first opened it up after sitting all winter. A squirrel had been nesting in my engine bay.

Any ideas why my scanner isn’t linking to the ECU?
Or why I’m not getting any acceleration?