Search results

  1. Bluebird

    Inner driver's side tire wear

    Hi all, Rotated the tires on the 16 GT and noticed excess wear on the inside of the driver's side tire. The other three tires appeared to wear evenly. Aside from taking it to an alignment place is there anything I can do to alleviate the uneven wear problem? Tires get rotated (by me) every 5000...
  2. Bluebird

    Rear brake pads replaced 2016 GT

    Even though there was some life remaining on the rear pads, I decided to replace them at 70600 miles. Put the car in Service Mode, heard the little motor on the E-brake spin, and figured I was ready to go. The dash light indicating a brake issue lit up (okay) but the message the car was in...
  3. Bluebird

    Pleased with front brake pads

    Greetings, Bought replacement front brake pads for the 2016 GT, 65000 miles. Upon removal of existing pads found there was still 9mm on outboard pad and 8mm on inboard pad on both sides. Cleaned and re-lubricated touch points and slapped back together. Figured I'd need new pads because I live...
  4. Bluebird

    VIN lookup has bad information

    On https://driving-tests.org/vin-decoder/ my decoded VIN says I have a turbo on my 2016 CX5 GT. I don't...I don't believe it was offered (not sure). I guess you can't believe everything you read on the Internet.
  5. Bluebird

    Compass grayed out

    First, I apologize if this question has been asked and answered before, but I couldn't find it with a search. On my 2016 GT AWD... After ejecting the SD card the display shows latitude, longitude, and elevation, those options are great. However, the compass located just above is grayed out and...
  6. Bluebird

    2013~2016 OEM battery leaks through caps

    Sorry, submitted twice.
  7. Bluebird

    2013~2016 OEM battery leaks through caps

    My 16 GT still has the original battery with six hard-to-turn screw caps. The caps have been leaking and the metal hold-down shows corrosion. I removed the battery and saw signs of leaked battery acid below, on the frame. Anybody else had this happen? The battery works fine.