What have you done to your Miata today?

chiefmg

MOTM July 2015
:
'81 RX-7 GS, '00 Miata SE, '16 Camaro (wife's), '15 CX-5 GT AWD

bazooka joe

No words
Contributor
:
2016 Miata Club, 2014 CX5 Touring, Honda 1976 XL 175
Great work on those lights Mike!
Packing up the car today. Heading back to MA Saturday morning. Should be home Sunday afternoon.
 
Last edited:

Reitrof

Contributor
:
2008 Miata PRHT; 2018 3
Bruce, any chance this is the MS front you are looking for: https://www.ebay.com/itm/06-08-Mazd...001628?hash=item2f14f40e1c:g:R0UAAOSwbP1aX82L

Just came across it while preusing eBay. I've bought from that seller before, he gets a lot of Mazda stuff cheaply.
Thanks but that one is to add to the bottom of the stock front bumper cover. The MazdaSpeed one is the entire front bumper cover. I will look this summer and see if some shop can fix the old one. I still have the original one and will use that with some front spoiler or air dam.

Found damage to the AC condenser and the insurance co is coming out to look at it.

Not much else is going on with Mia now since I have to wait for the adjuster. Some how need to check the rad and see if it's damaged. No leaks though. Was going to work on the car this weekend but they're predicting snow!!
 

chiefmg

MOTM July 2015
:
'81 RX-7 GS, '00 Miata SE, '16 Camaro (wife's), '15 CX-5 GT AWD
I'll keep my eyes open.

After some problems I have been seeing long term and a little combined research/cogitation, I decided to replace the alternator. Decided upon a NB2 rebuilt unit with 80 amp output (vice the 70 amp of the '00 stocker). Installed that today, while I was underneath I creeped the length of the car while she was running to look for any leaks or out of the ordinary stuff. Nothing presented thankfully. After that was done I went for a drive and did some datalogging. My voltage stayed constant throughout which was good, however I had two alarm lights under different circumstances. After that I sent a message to the Megasquirt builder to pick his brain about what I'm seeing.
 

bazooka joe

No words
Contributor
:
2016 Miata Club, 2014 CX5 Touring, Honda 1976 XL 175
Took her to my local Mazda dealer for a state (MA) inspection. I worked here last yr, and I know the guy doing the inspection. After driving the car in and starting the process he comes in and says he’s no sure I’ll pass because I don’t have a front plate. Luckily I had it in the trunk, I had forgotten I took it off last October when I drove down to NC. I’ve been down south for 4 months and of course didn’t run it there. I passed, 😉.
 

Attachments

bazooka joe

No words
Contributor
:
2016 Miata Club, 2014 CX5 Touring, Honda 1976 XL 175
Cleaned off a few dead bugs from a great ride yesterday to Diamond Hill Park in Cumberland RI with the brother in law and his wife. The ice cream shop across the street was packed with social distancing customers. Robin and I didn’t indulge, I need to avoid the calories!
 

Attachments

bazooka joe

No words
Contributor
:
2016 Miata Club, 2014 CX5 Touring, Honda 1976 XL 175
Went to my second cars and coffee event at Larz Anderson sat. It was virtual of course...maybe we can get back to in person/car events next month? Anyway, here’s my entry....the prop, which changes each event makes certain the picture is a current one. Last month was your car keys/fob and this month was a cup of joe.
 

Attachments

chiefmg

MOTM July 2015
:
'81 RX-7 GS, '00 Miata SE, '16 Camaro (wife's), '15 CX-5 GT AWD
Noticed that one of the CEL indicators on my log was the TPS. Checked out Rock Auto and found they had one for $10. I figured WTH, do a little research for the community. Received it and found the connector wouldn't snap locked. Comparing it with the factory TPS I noticed there are two divider pieces there are shorter on the stocker. Here are some blurry pictures that you can maybe see what I am talking about on:

Stock:


Aftermarket:


You are looking for the difference in depth in the dividers between the metal contacts.

I kind of figured since it was so cheap that maybe they got it wrong. Asked for a refund (which was given) and ordered a Walker replacement. That showed up today, wouldn't you know it the damn thing had the same problem for the same reason. Rock Auto didn't have me send the cheap one back, so I decided to see if I could modify it to work. A little Dremel work and voila! Connector snapped home like it should. I then took the Walker unit and did the same thing to it. That is now installed and calibrated on the Megasquirt. Hoping tomorrow clears so I can do a test drive with some data logging.
 

Antoine

Administrator
Great updates, guys...It's always a joy to follow along... @bazooka joe Nice angles on your Miata there, so they had a virtual Cars and Coffee...How does that work exactly? People video chat by their car using a phone?
 

bazooka joe

No words
Contributor
:
2016 Miata Club, 2014 CX5 Touring, Honda 1976 XL 175
Great updates, guys...It's always a joy to follow along... @bazooka joe Nice angles on your Miata there, so they had a virtual Cars and Coffee...How does that work exactly? People video chat by their car using a phone?
Thanks Antoine! All you do is post a pic or video of your car on their FB Ppage, people like It for the “people’s choice“ category and the museum staff does the judging for other virtual awards.
 
:
2016.5 CX-5 GT AWD titanium/black 2016 Miata Club ST MT white
Cleaned off a few dead bugs from a great ride yesterday to Diamond Hill Park in Cumberland RI with the brother in law and his wife. The ice cream shop across the street was packed with social distancing customers. Robin and I didn’t indulge, I need to avoid the calories!
That must have been a VERY crowded ride!
 
:
CX-5 AWD Grand Touring (Soul Red) + Tech.
Was not today, but last Sunday did a whole wash, clay, and wax. Was the first since purchasing back in March. Chemical Guys wash with foam gun, Meguiars clay, Turtle Wax Seal & Shine.

Photo taken before the clay and wax:

IMG_20200517_114538 (1).jpg
 

sm1ke

Work In Progress..
Moderator
Contributor
:
Canada
:
'18 CX-9 Signature
Was not today, but last Sunday did a whole wash, clay, and wax. Was the first since purchasing back in March. Chemical Guys wash with foam gun, Meguiars clay, Turtle Wax Seal & Shine.

Photo taken before the clay and wax:

View attachment 224813

Love the red. No polish after the clay?
 
:
CX-5 AWD Grand Touring (Soul Red) + Tech.
Love the red. No polish after the clay?
I don't have nor do I know how to polish...it needs it, though. Even after clay there were several contaminants still present in the paint visible to the naked eye.
 

sm1ke

Work In Progress..
Moderator
Contributor
:
Canada
:
'18 CX-9 Signature
I don't have nor do I know how to polish...it needs it, though. Even after clay there were several contaminants still present in the paint visible to the naked eye.
You can hand-polish, but its very labour intensive (I did it on my CX-9 before I bought a machine polisher). Its not really a necessary step, but a lot of the time the clay is just abrasive enough to leave minor swirl marks in the paint, especially on the softer Japanese paint.

I had the same issue with the clay I used recently (Meguiar's detailing clay). While claying off the contaminants on the doors, I noticed that it wasn't removing some stubborn bits. I sprayed on some Turtle Wax Bug & Tar Remover and let it dwell for 30-40 seconds, then rubbed with a microfiber cloth. You have to use some elbow grease, but it did the trick.
 

Antoine

Administrator
Was not today, but last Sunday did a whole wash, clay, and wax. Was the first since purchasing back in March. Chemical Guys wash with foam gun, Meguiars clay, Turtle Wax Seal & Shine.

Photo taken before the clay and wax:

View attachment 224813
What a beauty! Got a pic of the after (clay and wax)?

How has the ownership and driving experience been so far?
 

chiefmg

MOTM July 2015
:
'81 RX-7 GS, '00 Miata SE, '16 Camaro (wife's), '15 CX-5 GT AWD
I have had some problems lately with overheating as seen on my datalogs. Did some troubleshooting, it appeared the primary (driver’s side) fan wasn’t coming on or was running at a reduced speed. Further checks showed the fan ran fine with battery power. I also checked the input from the ECU with the A/C running (so both fans should be on), I had full voltage at the connector. Looking at the connector (a Radio Shack piece) it looked like one of the pieces was out of place which could have caused an issue. Here are what the connectors I used looked like, and the one with the connection out of place:





With that going on I decided to upgrade to more modern connectors as shown:



Purchased from Amazon (https://www.amazon.com/gp/product/B014IU2EE2/?tag=m20b7-20) . They are pretty easy to use, you need to put the seals on the wires before attaching the metal connectors.



There were instructions included showing the orientation of the metal pieces so they will lock correctly into the plastic piece. On the female side there was a red plastic piece that the instructions said you could use or not. I found I couldn’t use them as they wouldn’t allow the metal pieces to snap into place. I ended up cutting some back as shown, then they worked as designed:





When you push the metal pieces into place, you can hear and feel them lock. Pushing the yellow wire seals in place required a little persuasion from a small flat blade screwdriver (I wouldn’t use something as small as a jeweler’s screwdriver as you might end up ripping the seal) but it wasn’t too bad. That’s all done, I’ll see how things work next time out.
 
Top