Dome Light on Driver's Side Won't Turn Off

Armchair Bronco

'07 CX-9 GT AWD Owner
:
2007 Mazda CX-9 GT AWD
Map Light on Driver's Side Won't Turn Off

The front seat driver's side dome light on my wife's 2007 CX-9 won't turn off.

Yesterday, she was shopping w/ my daughter and one of her friends. They opened up the hatch, loaded up the car, and got inside. That's when my wife noticed that her front seat dome light stayed on. She doubled-checked to make sure all door were closed (they were) but the light still wouldn't go off.

I tried everything I could think of, but the dang thing has been on all night long.

Any ideas? It could be the ceiling switch itself, but it seems like it might also be a faulty door ajar sensor.

The car is out of warranty and I don't want to spend $100 or more to turn off a light! The cheapest hack would be to just take out the bulb. How can I safely remove the plastic cover to get at the bulb?
 
Last edited:

Davicho

"The One And Only"
:
ZoomZoom
If it is ONLY the left side dome light that is staying on, it is NOT any of the door switches otherwise all domes lights would stay on. If you have tried to turn off the light by pressing the left map light switch and it is still not turning off my sugestion is the entire front dome lamp assembly is bad. I do not think they are very expensive (although I could be wrong).
 

Wagonbacker9

Jack of all asses
:
2004 'Hoe
is there a switch for/on that particular light? I know it sounds dumb... but... i'm going by the KISS rule here.
 

Armchair Bronco

'07 CX-9 GT AWD Owner
:
2007 Mazda CX-9 GT AWD
Hey, I fixed it!

I used a small cheese fork to pop off the plastic cover from the left map light. As soon as I did this, the light turned off and was back in working order. Yay!

I'm guessing that the light bulb (it looks like it's a halogen bulb) or some part of the assembly itself came loose yesterday and somehow shorted the circuit so that it was always on. Apparently, popping off the cover was enough to wiggle things back in place.

This *could* be the early warning signs of a bigger problem down the road, but for now at least everything seems to be fine.

Thanks for the feedback.
 
:
2007 GT FWD, Bose/NAV
Hey, I fixed it!

I used a small cheese fork to pop off the plastic cover from the left map light. As soon as I did this, the light turned off and was back in working order. Yay!

I'm guessing that the light bulb (it looks like it's a halogen bulb) or some part of the assembly itself came loose yesterday and somehow shorted the circuit so that it was always on. Apparently, popping off the cover was enough to wiggle things back in place.

This *could* be the early warning signs of a bigger problem down the road, but for now at least everything seems to be fine.

Thanks for the feedback.

Sure.... you just found the on/off button. :p
 

Armchair Bronco

'07 CX-9 GT AWD Owner
:
2007 Mazda CX-9 GT AWD
For those without an CX-9, here's what I was up against. As you can see, the OFF/DOOR/ON switch is nicely labeled.

4117-064-ceiling-controls-480.jpg


This wasn't the problem. Instead, it was inside the left-hand side recess where the bulb is housed. You can pop off the plastic cover by jamming a small, thin fork or screwdriver on the leading edge of the cover.
 
:
2007 GT FWD, Bose/NAV
Even after pushing that button in/out to the side of the on/off switch for the dome it would not turn off?
 

Armchair Bronco

'07 CX-9 GT AWD Owner
:
2007 Mazda CX-9 GT AWD
Even after pushing that button in/out to the side of the on/off switch for the dome it would not turn off?

Nope. I tried the slider switch in all positiosn, and I pushed the adjacent button in and out repeatedly. Also manually tested all of the door switches. Nuttin' worked, and the darn thing burned through the night.

But when I popped off the cover, it must have jarred something on the way out. As soon as it came off, the light turned off.

That's my story, and I'm sticking to it!
 
Ok...I'm having this problem with my 02 protege5...If I push the button, the light gets much brighter, but will not turn off and it's only the driver’s side.

Gonna try to take the cover off and see if that is my fix as well...smh