2013~2016 2016 cx5 rear pad replace

new here, a little thing is happening sometimes. replaced rear pads, yes i put in maintenance mode, did not rotate piston while retracting. replaced pads, cleaned and re-lubed pins etc. took out of maintenance mode and test drove. seemed fine. then epb wouldn't release on right side sometimes. pulled wheel and dust boot wasn't looking right almost as it rotated. refolded boot only and reassembled, piston markings still up/down. still having release issue, but seems if when applying epb ,i do not press brake pedal, this seems to work? thanks
 

yrwei52

2016 Mazda CX-5 GT AWD w/Tech Pkg
Contributor
:
Plano, Texas, USA
new here, a little thing is happening sometimes. replaced rear pads, yes i put in maintenance mode, did not rotate piston while retracting. replaced pads, cleaned and re-lubed pins etc. took out of maintenance mode and test drove. seemed fine. then epb wouldn't release on right side sometimes. pulled wheel and dust boot wasn't looking right almost as it rotated. refolded boot only and reassembled, piston markings still up/down. still having release issue, but seems if when applying epb ,i do not press brake pedal, this seems to work? thanks
If youd followed every suggestion in the following thread:

Maintenance Mode for 2016/2017 CX-5 electronic brakes

Then your problem could be caused by flawed rear disk caliper from factory. Unfortunately you may need a new set of revised rear disk calipers to resolve the issue. See the the second TSB here for detail:

TSB 04-005/16: Noise from Rear Brakes Due To Brake Drag

TSB R052/16C: Noise from REAR BRAKE/Trace of Rear Brake Dragging